From: Johannes Schindelin Date: Wed, 04 May 2016 11:05:37 GMT Subject: Re: [PATCH 1/2] bisect--helper: use OPT_CMDMODE instead of OPT_BOOL Message-ID: In-Reply-To: Hi Christian, On Wed, 4 May 2016, Christian Couder wrote: > On Wed, May 4, 2016 at 8:07 AM, Eric Sunshine wrote: > > On Wed, May 4, 2016 at 1:07 AM, Pranit Bauva wrote: > >> bisect--helper: use OPT_CMDMODE instead of OPT_BOOL > > > > This subject is too low-level, talking about implementation details, > > whereas it should be giving a high-level summary of the change. > > When a patch is all about a low level detail, I think it is good to > talk about the detail in the subject. Well, this is not the case here. The intent of this commit is to prepare for other command modes. So... why not just say "bisect--helper: prepare for modes other than 'next-all'"? Ciao, Dscho