From: Johannes Schindelin Date: Fri, 15 Jan 2010 17:12:41 GMT Subject: Re: [PATCH] Add push --set-upstream Message-ID: In-Reply-To: Hi, On Fri, 15 Jan 2010, Matthieu Moy wrote: > Ilari Liusvaara writes: > > > + OPT_BIT('u', "set-upstream", &flags, "Set upstream for git pull", TRANSPORT_PUSH_SET_UPSTREAM), > > I'd be in favor of --track for the option name. Not that it's the best > name ever, but this is really doing the same job as branch --track and > checkout --track, so it should have the same name. > > Or the --track option of branch and checkout should be renamed as > --set-upstream, but that seems a lot of trouble for little benefit. Junio already complained that it is a bad name, basically because it is ambiguous. If you are really pushing for --track, you will have to think of a compelling reasoning. Ciao, Dscho P.S.: FWIW I think --set-upstream is really a good name.