From: Johannes Schindelin Date: Fri, 16 Oct 2009 11:32:38 GMT Subject: Re: [PATCH 3/3] Add proof-of-concept %[w(width,in1,in2)<>%] implementation Message-ID: In-Reply-To: <1255681702-5215-4-git-send-email-gitster@pobox.com> Hi, maybe "rewrap" would be a better name than "w"? On Fri, 16 Oct 2009, Junio C Hamano wrote: > #1 "%[" introduces the nested string function. > > #2 After that, a name identifies what function to call. > > #3 The function parses its parameters ("(72,4,8)" in the above example), > and makes a nested expansion on the remainder of the format string. Can't we parse it once, i.e. the first time? Ciao, Dscho