From: Johannes Schindelin Date: Sun, 05 Apr 2009 13:11:48 GMT Subject: Re: [PATCH 1/4] sha1-lookup: add new "sha1_pos" function to efficiently lookup sha1 Message-ID: In-Reply-To: <20090404225926.a9ad50e0.chriscool@tuxfamily.org> Hi, On Sat, 4 Apr 2009, Christian Couder wrote: > This function has been copied from the "patch_pos" function in > "patch-ids.c" but an additional parameter has been added. > > The new parameter is a function pointer, that is used to access the > sha1 of an element in the table. Frankly, this is hard to follow. It would have been easier if the first patch added that parameter, and the second patch just _moved_ the function. Ciao, Dscho