From: Johannes Schindelin Date: Sun, 15 Feb 2009 12:24:33 GMT Subject: Re: [PATCH 4/8] config: Improve variable 'type' handling. Message-ID: In-Reply-To: <1234688460-9248-4-git-send-email-felipe.contreras@gmail.com> Hi, On Sun, 15 Feb 2009, Felipe Contreras wrote: > + switch (types) { > + case TYPE_BOOL: type = T_BOOL; break; > + case TYPE_INT: type = T_INT; break; > + case TYPE_BOOL_OR_INT: type = T_BOOL_OR_INT; break; > + default: break; > + } Would it not be nicer to get rid of the variable named "type" and use "types == TYPE_BOOL" and similar statements instead? Ciao, Dscho