From: Johannes Schindelin Date: Sat, 14 Feb 2009 18:47:36 GMT Subject: Re: [PATCH] rerere: remove duplicated functions Message-ID: In-Reply-To: <1234628284-4246-1-git-send-email-szeder@ira.uka.de> Hi, On Sat, 14 Feb 2009, SZEDER Gábor wrote: > diff --git a/rerere.h b/rerere.h > index f9b0386..45b5087 100644 > --- a/rerere.h > +++ b/rerere.h > @@ -5,5 +5,7 @@ > > extern int setup_rerere(struct string_list *); > extern int rerere(void); > +extern const char *rr_path(const char *name, const char *file); > +extern int has_resolution(const char *name); You might argue that rr_path() is a unique enough name (although I'd rather name it rerere_path() instead), but has_resolution() is not a good description of what the function does when it lives in the global name space. has_rerere_resolution() (with "hex" instead of "name", to make it obvious what the parameter actually _is_) should be a much better name. Thanks, Dscho