From: Johannes Schindelin Date: Fri, 04 Jul 2008 12:35:24 GMT Subject: Re: [PATCH 1/2] help.c: Add support for htmldir relative to git_exec_path() Message-ID: In-Reply-To: <7vk5g2uhi9.fsf@gitster.siamese.dyndns.org> Hi, On Fri, 4 Jul 2008, Junio C Hamano wrote: > Could you check if there are copy-and-pasted duplicated code you can > factor out before continuing this direction? Note also that Hannes tried very hard to get rid of those ugly "#ifdef __MINGW32__"s by declaring/overriding functions in git-compat-util.h. I think that is such a good practice that we should not stop here. Ciao, Dscho