From: Johannes Schindelin Date: Thu, 15 May 2008 09:06:22 GMT Subject: Re: [PATCH v2] Add support for GIT_CEILING_DIRS Message-ID: In-Reply-To: <482BF69C.6020604@viscovery.net> Hi, On Thu, 15 May 2008, Johannes Sixt wrote: > + do { } while (offset > ceil_offset && cwd[--offset] != '/'); You probably meant to remove the "do { }", and have an own line ; /* do nothing */ but for the rest, I agree that it is easier on the eye (particularly the off-by-one issue, which is always a problem for this developer to get right; avoiding it is therefore the better option). Ciao, Dscho