From: Patrick Steinhardt Date: Wed, 11 Feb 2026 12:13:44 GMT Subject: Re: [PATCH 5/5] config: make 'git config list --type=' work Message-ID: In-Reply-To: On Tue, Feb 10, 2026 at 04:42:59AM +0000, Derrick Stolee via GitGitGadget wrote: > From: Derrick Stolee > > Previously, the --type= argument to 'git config list' was ignored and > did nothing. Now, we add the use of format_config() to the > show_all_config() function so each key-value pair is attempted to be > parsed. > > If there is an error in parsing, then the row is not output. I was a bit surprised at first, but now that I think about it a bit more I think this is sensible behaviour. If I ask for `git config list --type=int`, then I don't want to see any non-int configuration. I wouldn't even expect a warning, as the option essentially works like a filter. > This is a change in behavior! We are starting to respect an option that > was previously ignored, leading to potential user confusion. This is > probably still a good option, since the --type argument did not change > behavior at all previously, so users can get the behavior they expect by > removing the --type argument or adding the --no-type argument. Yeah, I fully agree that this is a sensible change in behaviour. It is obviously broken right now, so I would claim that this is simply a bug fix. > diff --git a/Documentation/git-config.adoc b/Documentation/git-config.adoc > index ac3b536a15..5300dd4c51 100644 > --- a/Documentation/git-config.adoc > +++ b/Documentation/git-config.adoc The synopsis of `git config list` should also be amended. > diff --git a/builtin/config.c b/builtin/config.c > index e69b26af6a..c83514b4ff 100644 > --- a/builtin/config.c > +++ b/builtin/config.c > @@ -363,21 +363,12 @@ static int show_all_config(const char *key_, const char *value_, > { > const struct config_display_options *opts = cb; > const struct key_value_info *kvi = ctx->kvi; > + struct strbuf formatted = STRBUF_INIT; > > - if (opts->show_origin || opts->show_scope) { > - struct strbuf buf = STRBUF_INIT; > - if (opts->show_scope) > - show_config_scope(opts, kvi, &buf); > - if (opts->show_origin) > - show_config_origin(opts, kvi, &buf); > - /* Use fwrite as "buf" can contain \0's if "end_null" is set. */ > - fwrite(buf.buf, 1, buf.len, stdout); > - strbuf_release(&buf); > - } > - if (!opts->omit_values && value_) > - printf("%s%c%s%c", key_, opts->delim, value_, opts->term); > - else > - printf("%s%c", key_, opts->term); > + if (format_config(opts, &formatted, key_, value_, kvi, 0) >= 0) > + fwrite(formatted.buf, 1, formatted.len, stdout); > + > + strbuf_release(&formatted); > return 0; > } > I wonder whether there is a good argument to be made here that we should keep the old logic in case no "--type=" parameter was given. In that case, for example the following output would remain the same: > diff --git a/t/t1300-config.sh b/t/t1300-config.sh > index 9850fcd5b5..b5ce900126 100755 > --- a/t/t1300-config.sh > +++ b/t/t1300-config.sh > @@ -2459,9 +2459,10 @@ done > > cat >.git/config <<-\EOF && > [section] > -foo = true > +foo = True > number = 10 > big = 1M > +path = ~/dir > EOF > > test_expect_success 'identical modern --type specifiers are allowed' ' I'm not really sure whether we want that though. I actually like that this also leads to some code duplication, so maybe this is fine? Patrick