From: Patrick Steinhardt Date: Mon, 13 Oct 2025 06:13:03 GMT Subject: Re: [PATCH v4 4/7] builtin/repo: introduce stats subcommand Message-ID: In-Reply-To: On Fri, Oct 10, 2025 at 09:34:54AM -0500, Justin Tobler wrote: > On 25/10/10 08:53AM, Patrick Steinhardt wrote: > > On Thu, Oct 09, 2025 at 07:42:40PM -0500, Justin Tobler wrote: > > > Thinking about this some more, a single "stats" command is indeed rather > > > vauge. Furthermore, as Junio mentioned, there could be other aspects of > > > a repository that we want to display stats for in the future. > > > > > > Since the goal of this command is to surface info about a repositories > > > structure, may we should instead call this command `git repo structure`? > > > Or something else along those lines that in more specific and related to > > > goal of the command? > > > > Some alternatives that come to my mind: > > > > - inspect > > - analyze > > - scan > > - survey > > - measure > > > > I don't have any specific preference. What I like though is that those > > are verbs, which makes it a bit more natural to use them. > > If we want the theme of this command to be the repository's > structure/shape and have a name that matches this scope, I'm not sure > any of the above examples would move us closer to that. Aligning the > command name to its scope is beneficial if we forsee the potential to > introduce additional subcommands for git-repo(1) that target other > aspects of a repository. Fair. > From my perspective, the main question is: should git-repo-stats be a > generic command that can eventual provides all sorts of different stats? > Or should it stick to repository structure/shape information? I think > I'm currently leaning towards the latter. Yeah, I'm leaning towards the latter, as well. Patrick