From: Taylor Blau Date: Fri, 10 Oct 2025 23:00:51 GMT Subject: Re: [PATCH 27/49] builtin/repack.c: rename various pack_geometry functions Message-ID: In-Reply-To: On Wed, Oct 08, 2025 at 06:26:29AM +0200, Patrick Steinhardt wrote: > On Tue, Oct 07, 2025 at 04:38:33PM -0400, Taylor Blau wrote: > > On Tue, Sep 30, 2025 at 01:22:05AM +0200, Patrick Steinhardt wrote: > > > On Sun, Sep 28, 2025 at 06:08:54PM -0400, Taylor Blau wrote: > > > > diff --git a/builtin/repack.c b/builtin/repack.c > > > > index 18c3df7200..2ce1ae3364 100644 > > > > --- a/builtin/repack.c > > > > +++ b/builtin/repack.c > > > > @@ -332,7 +332,7 @@ static void geometry_remove_redundant_packs(struct pack_geometry *geometry, > > > > strbuf_release(&buf); > > > > } > > > > > > > > -static void free_pack_geometry(struct pack_geometry *geometry) > > > > +static void pack_geometry_release(struct pack_geometry *geometry) > > > > { > > > > if (!geometry) > > > > return; > > > > > > Okay, this function also gets adjusted for the new naming schema we have > > > around free/release. Good, but it might be worth it to point it out in > > > the commit message. > > > > I wrote the commit message to be generic to cover "various pack_geometry > > functions". Did you want me to be more specific about which functions > > were renamed? > > Not in general, no. But I felt that this method here was somewhat > special because we not only rename to have `pack_geometry_` as prefix, > but also to use the correct verb. Aha, sorry, I see what you're saying. I'll make that clearer in my local version, thanks for suggesting it! Thanks, Taylor