From: Taylor Blau Date: Fri, 10 Oct 2025 22:52:26 GMT Subject: Re: [PATCH 11/49] repack: introduce new compilation unit Message-ID: In-Reply-To: <20251010054804.GD1965904@coredump.intra.peff.net> On Fri, Oct 10, 2025 at 01:48:04AM -0400, Jeff King wrote: > On Sun, Sep 28, 2025 at 06:07:53PM -0400, Taylor Blau wrote: > > > Let's start by migrating 'struct pack_objects_args' (and the related > > corresponding pack_objects_args_release() function) into repack.h, and > > teach both the Makefile and Meson how to build the new compilation unit. > > This name is a little generic for something that now has external scope, > since it is specific to repack's view of what it might want to pass to > pack_objects (and not something that builtin/pack-objects.c cares about > itself). > > I don't have a great alternative name, though. I guess it could be > repack_pack_objects_args or something, though that is getting to be a > mouthful. Yeah, I had considered `repack_pack_objects_args` initially for exactly that reason, but discarded it because I thought it was too wordy. > I dunno. Maybe it is OK as-is. If I stretch I can imagine a world where > pack_objects_args is for the lib-ified version of cmd_pack_objects() to > use (like we have send_pack_args, etc). But TBH I find it unlikely that > we'd go that way anytime soon (and if we did, we'd maybe even be able to > refactor repack to more directly use the struct offered by > pack-objects). I had a similar concern when writing this patch. I think that that world is far enough away that I am comfortable crossing that bridge if/when we get there ;-). Thanks, Taylor