From: Patrick Steinhardt Date: Fri, 25 Jul 2025 05:36:13 GMT Subject: Re: [PATCH 4/8] builtin/reflog: implement subcommand to write new entries Message-ID: In-Reply-To: <87o6t9kaua.fsf@iotcl.com> On Thu, Jul 24, 2025 at 02:54:53PM +0200, Toon Claes wrote: > Patrick Steinhardt writes: > > diff --git a/Documentation/git-reflog.adoc b/Documentation/git-reflog.adoc > > index 6ae13e772b8..798dbc0a00a 100644 > > --- a/Documentation/git-reflog.adoc > > +++ b/Documentation/git-reflog.adoc > > @@ -392,6 +403,59 @@ static int cmd_reflog_drop(int argc, const char **argv, const char *prefix, > > return ret; > > } > > > > +static int cmd_reflog_write(int argc, const char **argv, const char *prefix, > > + struct repository *repo) > > +{ > > + const struct option options[] = { > > + OPT_END() > > + }; > > + struct object_id old_oid, new_oid; > > + struct strbuf err = STRBUF_INIT; > > + struct ref_transaction *tx; > > + const char *ref, *message; > > + int ret; > > + > > + argc = parse_options(argc, argv, prefix, options, reflog_drop_usage, 0); > > Wrong usage string here: s/reflog_drop_usage/reflog_write_usage/. Good catch, fixed now. Patrick