From: Patrick Steinhardt Date: Tue, 01 Jul 2025 12:17:52 GMT Subject: Re: [PATCH v5 02/17] object-store: rename `object_directory` to `odb_source` Message-ID: In-Reply-To: On Sun, Jun 29, 2025 at 09:02:04PM -0500, Justin Tobler wrote: > On 25/06/05 08:46AM, Patrick Steinhardt wrote: > [snip] > > -struct object_directory *find_odb(struct repository *r, const char *obj_dir) > > +struct odb_source *find_odb(struct repository *r, const char *obj_dir) > > Since we renamed `object_directory` to `odb_source`, should instead call > this function `find_odb_source`? > > Otherwise, the renames in this patch look good to me. The name gets adjusted to `odb_find_source()` in a later patch. Patrick