From: Patrick Steinhardt Date: Wed, 12 Jun 2024 09:40:24 GMT Subject: Re: [PATCH 02/16] mktree: rename treeent to tree_entry Message-ID: In-Reply-To: <4558f35e7bf9a1594510951ee54252069bdcfc5b.1718130288.git.gitgitgadget@gmail.com> On Tue, Jun 11, 2024 at 06:24:34PM +0000, Victoria Dye via GitGitGadget wrote: > From: Victoria Dye > > Rename the type for better readability, clearly specifying "entry" (instead > of the "ent" abbreviation) and separating "tree" from "entry". > > Signed-off-by: Victoria Dye > --- > builtin/mktree.c | 10 +++++----- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/builtin/mktree.c b/builtin/mktree.c > index 8b19d440747..c02feb06aff 100644 > --- a/builtin/mktree.c > +++ b/builtin/mktree.c > @@ -12,7 +12,7 @@ > #include "parse-options.h" > #include "object-store-ll.h" > > -static struct treeent { > +static struct tree_entry { > unsigned mode; > struct object_id oid; > int len; This reads a ton better compared to `treeent`, thanks! I've never been a fan of abbreviations like this in code. Patrick