From: Emily Shaffer Date: Fri, 15 Oct 2021 16:25:59 GMT Subject: Re: [PATCH v2 05/13] hooks: convert 'post-checkout' hook to hook library Message-ID: In-Reply-To: On Tue, Oct 12, 2021 at 03:30:30PM +0200, Ævar Arnfjörð Bjarmason wrote: > > > Move the running of the 'post-checkout' hook away from run-command.h > to the new hook.h library. For "worktree" this requires a change to it > to run the hooks from a given directory. > > We could strictly speaking skip the "absolute_path" flag and just > check if "dir" is specified, but let's split them up for clarity, as > well as for any future user who'd like to set "dir" but not implicitly > change the argument to an absolute path. > > Signed-off-by: Emily Shaffer > Signed-off-by: Ævar Arnfjörð Bjarmason > --- a/read-cache.c > +++ b/read-cache.c > @@ -28,6 +28,7 @@ > #include "sparse-index.h" > #include "csum-file.h" > #include "promisor-remote.h" > +#include "hook.h" Hum, is this a stray line? I don't see any other change in read-cache.c? Otherwise, the change looks reasonable to me.