From: Taylor Blau Date: Thu, 09 Sep 2021 21:11:26 GMT Subject: Re: [PATCH 6/9] index-pack: refactor renaming in final() Message-ID: In-Reply-To: On Thu, Sep 09, 2021 at 12:45:04PM -0700, Junio C Hamano wrote: > Taylor Blau writes: > > > But since we've got "rev" as well now, let's do the renaming via a > > helper, this is both a net decrease in lines, and improves the > > readability,... > > xyz_ may be cute, but is distracting. I do not think it loses any > information if we used final_name, current_name, etc.; it may make > the result even easier to read. > > [...] > > make-read-only-if-same or somesuch? Both of these suggestions (dropping the "xyz"s and renaming the last parameter to "make_read_only_if_same") make sense. Will apply. Thanks, Taylor