From: Jeff King Date: Tue, 01 Jun 2021 15:55:17 GMT Subject: Re: [PATCH 2/2] [GSOC] cat-file: merge two block into one Message-ID: In-Reply-To: On Tue, Jun 01, 2021 at 02:35:57PM +0000, ZheNing Hu via GitGitGadget wrote: > From: ZheNing Hu > > Because the two "if (opt->all_objects)" block > are redundant, merge them into one, to provide > better readability. Funny indentation of the commit message. :) I think this is worth doing, and I agree the end-result is easier to read. Really minor nit, but I probably wouldn't have said "redundant" here. The conditionals themselves are redundant, but not the blocks. Maybe: There are two "if (opt->all_objects)" blocks next to each other; merge them into one to provide better readability. (not a huge deal, as I think seeing the patch helps explain what is going on. But again, just trying to offer polishing advice for future patches)