From: Johannes Schindelin Date: Sun, 02 Dec 2007 11:35:48 GMT Subject: Re: [PATCH 0/3] Call builtin functions directly, was Re: [PATCH] transport.c: call dash-less form of receive-pack and upload-pack on remote Message-ID: In-Reply-To: <7v3aul1xmt.fsf@gitster.siamese.dyndns.org> Hi, On Sat, 1 Dec 2007, Junio C Hamano wrote: > Johannes Schindelin writes: > > > Okay, I bit the apple and tried to move the builtins into the library, > > and rename handle_internal_command into execv_git_builtin(), moving it > > into exec-cmd.c. > > > > Big mistake. > > I really feel this should not go in. Hmm. My rationale was not only avoiding an exec() (which I would find worth it on its own), but because this would be a non-verbal step towards libification. Ciao, Dscho