From: Brian Gernhardt Date: Tue, 17 Apr 2012 17:25:48 GMT Subject: test-mergesort conflict with stdlib.h Message-ID: On OS X 10.7.3, I get the following error attempting to build next: CC test-mergesort.o In file included from test-mergesort.c:2: ./mergesort.h:4:7: error: conflicting types for 'mergesort' void *mergesort(void *list, ^ /usr/include/stdlib.h:306:6: note: previous declaration is here int mergesort(void *, size_t, size_t, ^ This appears to be due to the fact that 0db71e0: "add mergesort() for linked lists" added a mergesort implementation with a different signature than a mergesort implemented by OS X's standard library. Perhaps git could use a less generic name like 'llist_mergesort'? ~~ Brian Gernhardt