From: Brian Gernhardt Date: Wed, 16 Mar 2011 16:29:52 GMT Subject: Re: [PATCH 2/3] Name make_*_path functions more accurately Message-ID: In-Reply-To: <1300291579-25852-3-git-send-email-cmn@elego.de> On Mar 16, 2011, at 12:06 PM, Carlos Martín Nieto wrote: > Rename the make_*_path functions so it's clearer what they do, in > particlar make clear what the differnce between make_absolute_path and > make_nonrelative_path is by renaming them real_path and absolute_path > respectively. make_relative_path has an understandable name and is > renamed to relative_path to maintain the name convention. > > Signed-off-by: Carlos Martín Nieto I didn't try it, but it looks like 2/3 horribly breaks the code and 3/3 fixes it. I personally (and I think others) prefer patches that are each useful on their own. Especially since a code-breaking patch like this makes bisecting harder. I would suggest doing one of the following: 1) Squashing 2/3 and 3/3 so all the renaming occurs at once. 2) Adding wrappers from the old name to the new in 2/3 and removing them in 3/3. That said, I'm not sure the renaming is useful although the documentation comments definitely are. ~~ Brian