From: Brian Gernhardt Date: Tue, 17 Apr 2012 17:55:40 GMT Subject: Re: test-mergesort conflict with stdlib.h Message-ID: In-Reply-To: <7vd376ntem.fsf@alter.siamese.dyndns.org> On Apr 17, 2012, at 1:46 PM, Junio C Hamano wrote: > Unfortunate. OS X shouldn't contaminate the user namespace by adding such > names in stdlib.h (which incidentally has qsort()), but the damage is done > already, so I am not opposed to rename it to llist_mergesort() or something. This seems to be inherited from BSD's userspace which also has a mergesort (radixsort as well). I'll make a patch to rename it and if anyone doesn't like llist_mergesort, they can repaint the bikeshed themselves. ~~ Brian Gernhardt