From: Eric Sunshine Date: Mon, 15 Feb 2016 18:35:03 GMT Subject: Re: [PATCH 1/4] remote: use skip_prefix Message-ID: In-Reply-To: <20160215181837.GE26443@sigill.intra.peff.net> On Mon, Feb 15, 2016 at 1:18 PM, Jeff King wrote: > This is definitely an improvement, but I think we can actually go a step > further here, and use parse_config_key. Like: > > - if (starts_with(key, "branch.")) { > - name = key + 7; > - subkey = strrchr(name, '.'); > - if (!subkey) > + if (starts_with(key, "branch", &name, &namelen, &subkey)) { I guess you meant: s/starts_with/parse_config_key/ > + if (!name) > return 0; > - branch = make_branch(name, subkey - name); > + branch = make_branch(name, namelen); > if (!strcmp(subkey, ".remote")) { > return git_config_string(&branch->remote_name, key, value); > } else if (!strcmp(subkey, ".pushremote")) {