From: Eric Sunshine Date: Fri, 01 Jun 2018 08:04:00 GMT Subject: Re: [PATCH v4 9/9] checkout & worktree: introduce checkout.defaultRemote Message-ID: In-Reply-To: On Thu, May 31, 2018 at 5:49 PM, Stefan Beller wrote: >> I considered splitting this into checkout.defaultRemote and >> worktree.defaultRemote, but it's probably less confusing to break our >> own rules that anything shared between config should live in core.* >> than have two config settings, and I couldn't come up with a short >> name under core.* that made sense (core.defaultRemoteForCheckout?). > > core.dwimRemote ? It's a bit cryptic, though. This option started out as 'core.dwimRemote' in the very first version of this series[1], but someone argued against it for several reasons and suggested 'defaultRemote' instead[2]. [1]: https://public-inbox.org/git/20180502105452.17583-1-avarab@gmail.com/ [2]: https://public-inbox.org/git/CAPig+cTZyYC-1_TxL2PrfOF6HAktUxxM+g5EXcByS5fCDMdCHg@mail.gmail.com/