From: Eric Sunshine Date: Fri, 22 Apr 2016 17:19:21 GMT Subject: Re: [PATCH v8 5/6] verify-tag: move tag verification code to tag.c Message-ID: In-Reply-To: <1461336725-29915-6-git-send-email-santiago@nyu.edu> On Fri, Apr 22, 2016 at 10:52 AM, wrote: > The PGP verification routine for tags could be accessed by other modules > that require to do so. > > Publish the verify_tag function in tag.c and rename it to gpg_verify_tag > so it does not conflict with builtin/mktag's static function. > > Helped-by: Junio C Hamano > Signed-off-by: Santiago Torres > --- > diff --git a/tag.c b/tag.c > @@ -6,6 +6,59 @@ > +int gpg_verify_tag(const unsigned char *sha1, const char *name_to_report, Nit: This line has trailing whitespace. Probably not worth a re-roll. > + unsigned flags) > +{ > + enum object_type type; > + char *buf; > + unsigned long size; > + int ret; > + > + type = sha1_object_info(sha1, NULL); > + if (type != OBJ_TAG) > + return error("%s: cannot verify a non-tag object of type %s.", > + name_to_report ? > + name_to_report : > + find_unique_abbrev(sha1, DEFAULT_ABBREV), > + typename(type)); > + > + buf = read_sha1_file(sha1, &type, &size); > + if (!buf) > + return error("%s: unable to read file.", > + name_to_report ? > + name_to_report : > + find_unique_abbrev(sha1, DEFAULT_ABBREV)); > + > + ret = run_gpg_verify(buf, size, flags); > + > + free(buf); > + return ret; > +}