From: Eric Sunshine Date: Thu, 23 Jul 2020 23:46:41 GMT Subject: Re: [PATCH v3 34/39] t: add test_oid option to select hash algorithm Message-ID: In-Reply-To: <20200723233815.GB1758454@crustytoothpaste.net> On Thu, Jul 23, 2020 at 7:39 PM brian m. carlson wrote: > On 2020-07-23 at 04:51:32, Eric Sunshine wrote: > > On Wed, Jul 22, 2020 at 9:11 PM brian m. carlson > > wrote: > > > + --hash=*) > > > + algo="${1#--hash=}" && > > > > Bikeshedding: I wonder if this should be named "--algo"? > > We already have a use of this in t5515; I appear to have accidentally > sent it in an earlier series. I can, of course, change it, but I don't > feel strongly that one or the other is better. If you do feel strongly, > or you think it's confusing, I'm happy to change it. I don't feel strongly about it and wouldn't insist that it be changed.