From: Eric Sunshine Date: Tue, 10 May 2016 19:59:42 GMT Subject: Re: [PATCH 5/6] t1500: avoid setting environment variables outside of tests Message-ID: In-Reply-To: On Tue, May 10, 2016 at 3:48 PM, Eric Sunshine wrote: > Actually, I think we can have improved encapsulation and maintain > readability like this: > > case "$1" in > ... > -g) env="$2"; shift; shift ;; > ... > esac > > ... > test_expect_success "..." ' > if test -n "$env" > do > test_when_finished "unset GIT_DIR" > GIT_DIR="$env" > export GIT_DIR > fi > ... > ' At this point, I'd also rename 'env' to 'gitdir' to be more meaningful.