From: Christian Couder Date: Sun, 01 May 2016 16:53:08 GMT Subject: Re: [PATCH 53/83] builtin/apply: make find_header() return -1 instead of die()ing Message-ID: In-Reply-To: On Wed, Apr 27, 2016 at 8:10 PM, Eric Sunshine wrote: > On Mon, Apr 25, 2016 at 9:18 AM, Duy Nguyen wrote: >> On Sun, Apr 24, 2016 at 8:33 PM, Christian Couder >> wrote: >>> To be compatible with the rest of the error handling in builtin/apply.c, >>> find_header() should return -1 instead of calling die(). >>> >>> Unfortunately find_header() already returns -1 when no header is found, >>> so let's make it return -2 instead in this case. >> >> I don't think this is a good way to go. Too many magic numbers. I >> don't have a better option though. Maybe returning names instead of >> numbers would help a bit. > > I suppose 'hdrsize' could signal this extra condition. For instance, > always return -1 on error, and set hdrsize to 0 for header not found > (unless 0 is a valid size?), and -1 for any other error. > > But perhaps that's getting too clever... Yeah, I don't think it would make reading the patch simpler.