From: Christian Couder Date: Sat, 18 Feb 2023 18:35:24 GMT Subject: Re: [PATCH 1/1] trace.c, git.c: remove unnecessary parameter to trace_repo_setup Message-ID: In-Reply-To: <20230215231428.68040-1-mcsm224@gmail.com> On Thu, Feb 16, 2023 at 12:36 AM Idriss Fekir wrote: > > From: idriss fekir I think the subject could be improved a bit more, and it looks like it's the second version of the patch, so something like the following might have been better: [PATCH v2 1/1] trace: remove unnecessary parameter to trace_repo_setup() (Please use "v3" if you resend it with some changes.) > trace_repo_setup of trace.c is called with the argument 'prefix' from > only one location, run_builtin of git.c, which sets 'prefix' to > the return value of setup_git_directory or setup_git_directory_gently > (a wrapper of the former). It might be a bit easier to read when functions names have "()" after them like "trace_repo_setup()" instead of "trace_repo_setup". Otherwise your patch looks good to me. Thanks!