From: Christian Couder Date: Wed, 04 May 2016 06:50:56 GMT Subject: Re: [PATCH 1/2] bisect--helper: use OPT_CMDMODE instead of OPT_BOOL Message-ID: In-Reply-To: On Wed, May 4, 2016 at 8:07 AM, Eric Sunshine wrote: > On Wed, May 4, 2016 at 1:07 AM, Pranit Bauva wrote: >> bisect--helper: use OPT_CMDMODE instead of OPT_BOOL > > This subject is too low-level, talking about implementation details, > whereas it should be giving a high-level summary of the change. When a patch is all about a low level detail, I think it is good to talk about the detail in the subject. Here I think something like "bisect--helper: parse options using OPT_CMDMODE instead of OPT_BOOL" would be ok for example. >> `--next-all` is meant to be used as a sub command to support multiple >> "operation mode" though the current implementation does not contain any >> other sub command along side with `--next-all` but further commits will >> include some more subcommands. > > You've spelled this as both "sub command" and "subcommand". Choose one > and stick with it. ("subcommand" is probably more common.) I agree with that and the other suggestions, thanks.