From: Christian Couder Date: Mon, 18 Nov 2013 10:42:04 GMT Subject: Re: [PATCH 00/86] replace prefixcmp() with has_prefix() Message-ID: In-Reply-To: <20131117.095200.299497690980619465.chriscool@tuxfamily.org> On Sun, Nov 17, 2013 at 9:52 AM, Christian Couder wrote: > From: Jeff King >> >> On Wed, Nov 13, 2013 at 07:47:03AM +0100, Christian Couder wrote: >> >>> My preference is: >>> >>> 1) with an "s" >>> 2) "start" >>> 3) underscore >>> >>> so that gives: starts_with() and ends_with() >> >> FWIW, that looks good to me, too. Whether there is confusion over the >> meaning of "suffix" or not, it makes sense, all other things being >> equal, to use the same terms as other popular languages. >> >> Like you, I prefer "with an s", but we are deep in bikeshedding >> territory now. I can live with anything. :) > > When I prepared a new version of my patch series, this time to rename > suffixcmp() to ends_with(), it appeared that we already have a static > ends_with() function in vcs-svn/fast_export.c with another slightly > different implementation :-) > > I will send a new version that will remove this redundant > implementation. There is also a new version of my 86 patch long series to replace prefixcmp() with starts_with() that I am ready to send, but I hesitate to spam the whole list :-) I can put it somewhere like GitHub where people can see everything and perhaps send only a few patches to the list, including the first and the last. @Junio, how would you like me to proceed? Thanks, Christian.