From: Karthik Nayak Date: Mon, 03 Nov 2025 13:39:08 GMT Subject: Re: [PATCH v3 00/13] Carve out loose object source Message-ID: In-Reply-To: <20251103-b4-pks-odb-loose-backend-v3-0-6a61ea977393@pks.im> Patrick Steinhardt writes: [snip] > Range-diff versus v2: > > 1: 330b7c17e6a = 1: ed548a7ee4e odb: fix subtle logic to check whether an alternate is usable > 2: 68b2e736d20 = 2: 59d5548ddfa odb: introduce `odb_source_new()` > 3: b6f9a3f6d26 = 3: a417bd30153 odb: adjust naming to free object sources > 4: fe38c58ab20 = 4: add2b7d112f object-file: move `fetch_if_missing` > 5: 5fed6e7c429 ! 5: 5245ba0c6a5 object-file: introduce `struct odb_loose_source` > @@ Metadata > Author: Patrick Steinhardt > > ## Commit message ## > - object-file: introduce `struct odb_loose_source` > + object-file: introduce `struct odb_source_loose` > > Currently, all state that relates to loose objects is held directly by > - the `struct odb_source`. Introduce a new `struct odb_loose_source` to > + the `struct odb_source`. Introduce a new `struct odb_source_loose` to > hold the state instead so that it is entirely self-contained. > > This structure will eventually morph into the backend for accessing > @@ object-file.c: void object_file_transaction_commit(struct odb_transaction *trans > free(transaction); > } > + > -+struct odb_loose_source *odb_loose_source_new(struct odb_source *source) > ++struct odb_source_loose *odb_source_loose_new(struct odb_source *source) > +{ > -+ struct odb_loose_source *loose; > ++ struct odb_source_loose *loose; This is one of the points that Junio mentioned and I think the new naming schemes flows more naturally into. Nice. The range-diff looks good to me. Thanks.