From: Karthik Nayak Date: Wed, 24 Jun 2015 19:51:52 GMT Subject: [PATCH v5 00/11] add options to for-each-ref Message-ID: v4 of this patch series can be found here : http://article.gmane.org/gmane.comp.version-control.git/272285 This is a continuation of my GSoC project to unify git tag -l, git branch -l and for-each-ref. Continued from this patch series : http://thread.gmane.org/gmane.comp.version-control.git/271563 Changes in v5: 03/11: grammatical changes. 04/11: grammatical changes. 05/11: remove unnecessary if statement and remove caps used in commit message. 06/11: use xcalloc instead of using a commit_list as we know the size of the array. 07/11: s//[]/ as the object is optional. 08/11: rename parse_opt_commit_object_name() to parse_opt_commits(). 09/11: make branch.c also to use the macros. 11/11: s//[]/ as the object is optional. Thanks to Matthieu, Christian, Junio and Eric for the input on the last iteration. -- Regards, Karthik Nayak