From: Karthik Nayak Date: Wed, 17 Sep 2025 07:45:39 GMT Subject: Re: [PATCH v3 0/4] refs/files: fix issues with git-fetch on case-insensitive FS Message-ID: In-Reply-To: Junio C Hamano writes: > Karthik Nayak writes: > >> Changes in v3: >> - Rename duplicate_reference_case_cmp() to >> transaction_has_case_conflicting_update() and add comments. >> - Improve commit messages. >> - Add an additional test in the 4th commit to showcase D/F conflicts in >> case-sensistive file systems. >> - Link to v2: https://lore.kernel.org/r/20250908-587-git-fetch-1-fails-fetches-on-case-insensitive-repositories-v2-0-b2eb2459befb@gmail.com > > I think I like this "latest first and then historical" order in the > cover letter much better than the other way around. > > I see that this topic is pretty much done? There still are a few > questions from Justin's reply that may want to be answered, but I > have a feeling that the answer to them would not require a new > iteration. > > Looking good. Thanks. I did respond to Justin, I think there were a few small nits around grammar in the commit messages and a question around error reporting. I have applied the grammar fixes locally and don't think they warrant a re-roll. Regarding the error reporting. I think it is good the way it is. So I would say this is good as is and I will refrain for sending in a new version, unless there is some other concern. Thanks, Karthik