From: Karthik Nayak Date: Mon, 22 Jun 2015 15:38:41 GMT Subject: Re: [PATCH v4 08/19] parse-option: rename parse_opt_with_commit() Message-ID: In-Reply-To: On Mon, Jun 22, 2015 at 6:34 AM, Junio C Hamano wrote: > On Sun, Jun 21, 2015 at 1:48 PM, Karthik Nayak wrote: >> Rename parse_opt_with_commit() to parse_opt_commit_object_name() >> to show that it can be used to obtain a list of commits and is >> not constricted to usage of '--contains' option. > > I think that is a brilliant idea, but unlike the other function you > added earlier > that can do only one object and adopts "last one wins" rule, this is cumulative, > and that fact should be made clear to the developers in some way, no? Will add a comment :) Thanks! -- Regards, Karthik Nayak