From: Karthik Nayak Date: Wed, 17 Apr 2024 17:38:29 GMT Subject: Re: [PATCH 3/5] repository: initialize index in `repo_init()` Message-ID: In-Reply-To: <96256f9eb30e5aca632942169d5c311b1f245b40.1713180749.git.ps@pks.im> Patrick Steinhardt writes: > Refactor the code and create a common `initialize_repository()` function > that gets called from `repo_init()` and `initialize_the_repository()`. > This function sets up both the repository and the index as required. > Like this, we can easily special-case when `repo_init()` gets called > with `the_repository`. > Nit: `initialize_the_repository()` calling `initialize_repository()` doesn't really indicate what each of them does and why we have two functions which are similarly named but calling each other. Maybe we should rename them?