From: Jiang Xin Date: Wed, 06 Feb 2013 00:15:33 GMT Subject: Re: [PATCH v2 2/2] i18n: mark OPTION_NUMBER (-NUM) for translation Message-ID: In-Reply-To: <7vd2weu1sq.fsf@alter.siamese.dyndns.org> 2013/2/6 Junio C Hamano : > I somehow suspect that this is going in a direction that makes this > piece of code much less maintainable. > > Look at the entire function and see how many places you do fprintf > on strings that are marked with _(). short_name and long_name are > not likely to be translated, but everything else is, especially > multiple places that show _(opts->help) neither of these patches > touch. > > I wonder if it makes more sense to add a helper function that > returns the number of column positions (not bytes) with a signature > similar to fprintf() and use that throughout the function instead. I agree, a helper named 'utf8_fprintf' in utf8.c is better. I will send a patch latter. -- Jiang Xin