From: 徐迪 Date: Thu, 15 Mar 2012 10:35:28 GMT Subject: Re: [PATCH] Use macro HANDLER_WRAPPER in sigchain to wrap clean function of sigchain Message-ID: In-Reply-To: <7vlin4td4g.fsf@alter.siamese.dyndns.org> Eh. I really don't see why it is difficult to read. Although it _is_ error-prone, and also difficult to do further functionality extension. BTW, if we want to generalize the clean_xxx_on_signal, how should we deal with the exception I mentioned before(function named cleanup_children in run-command.c which require one argument)? By forcing all clean_xxx take one argument? Also, many books mentioned that we should never use signal() in portable program, use sigaction() instead, but there are plenty of signal() in git. Why should we do so?