From: Felipe Contreras Date: Sun, 08 Sep 2013 22:46:59 GMT Subject: Re: [PATCH 0/3] Reject non-ff pulls by default Message-ID: In-Reply-To: On Sun, Sep 8, 2013 at 1:10 PM, Junio C Hamano wrote: > pull. = rebase | merge [| always-fail] > > makes that choice in a clear way, I think. > > Regarding the verb "integrate". I doubt anybody thinks of pull being an "integration", and even if it is, it's still doesn't explain what 'integration = merge' means. To be human friendly you would need to say 'integration-type' or 'integration-kind', or 'integration-mode', then a human would understand, "oh yeah, the mode I'm using to integrated is a merge, got ya'. But why bother with yet another useless concept the user has to learn? The user doesn't need to learn about this concept of "integration", all the user wants is to map: git pull --rebase => pull. = rebase git pull --merge pull. = merge That's it. And my proposed name, 'mode' does the trick just fine. pull.mode = rebase | merge | merge-no-ff -- Felipe Contreras