From: Ramkumar Ramachandra Date: Wed, 13 Jul 2011 07:35:55 GMT Subject: Re: [PATCH 04/17] revert: Rename no_replay to record_origin Message-ID: In-Reply-To: <20110712170256.GC13578@elie> Hi Jonathan, Jonathan Nieder writes: > Ramkumar Ramachandra wrote: >> Rename the variable corresponding to the "-x" command-line option from >> "no_replay" to a more apt "record_origin". > > Why is it more apt?  What does "-x" do?  Why was it called "no_replay" > before?  Is there some other motivation to this change (e.g., does this > pave the way to using the name "replay" for something else)? Thanks for probing. Found out the reason after some digging. revert: Rename no_replay to record_origin The "-x" command-line option is used to record the name of the original commits being picked in the commit message. The variable corresponding to this option is named "no_replay" for historical reasons. This name was introduced in f810379 (Make builtin-revert.c use parse_options, 2007-10-07) to replace "replay", the opposite of "no_replay". The name "replay" was introduced in 9509af6 (Make git-revert & git-cherry-pick a builtin, 2007-03-01). Back then, "-x" was the only command-line option that modified the commit message of the commit being picked, and was in effect replaying a slightly different commit; hence the names "replay" and "no_replay". Today, there are many other options like "-s" which append various things to the commit message, and the term "replay" doesn't mean what it used to. So, give the variable corresponding to the "-x" command-line option a better name: "record_origin". -- Ram