From: Ramkumar Ramachandra Date: Wed, 14 Dec 2011 13:16:43 GMT Subject: Re: [PATCH 1/7] revert: give --continue handling its own function Message-ID: In-Reply-To: <20111210124736.GB22035@elie.hsd1.il.comcast.net> Hi Jonathan, Jonathan Nieder wrote: > This makes pick_revisions() a little shorter and easier to read > straight through. Ah, yes: you've asked about this earlier. Sounds sane; let's read ahead and see if anything jumps out. > diff --git a/builtin/revert.c b/builtin/revert.c > index 1ea525c1..9f6c85c1 100644 > --- a/builtin/revert.c > +++ b/builtin/revert.c > @@ -1038,6 +1038,21 @@ static int pick_commits(struct commit_list *todo_list, struct replay_opts *opts) > [...] > +static int sequencer_continue(struct replay_opts *opts) > +{ > +       struct commit_list *todo_list = NULL; > [...] >  static int pick_revisions(struct replay_opts *opts) >  { >        struct commit_list *todo_list = NULL; > [...] This is the only detailed that jumped out- you're filling up two different commit_list structures, depending on whether we're performing a fresh operation or continuing an existing one. Okay. Thanks. p.s- Sorry about the delay; just returned from a short vacation. -- Ram