From: Tay Ray Chuan Date: Thu, 26 Jul 2012 17:08:34 GMT Subject: Re: [PATCH v2 4/4] allow recovery from command name typos Message-ID: In-Reply-To: <7vtxwvbu5s.fsf@alter.siamese.dyndns.org> On Thu, Jul 26, 2012 at 1:57 AM, Junio C Hamano wrote: > > Tay Ray Chuan writes: > > > If suggestions are available (based on Levenshtein distance) and if the > > terminal isatty(), present a prompt to the user to select one of the > > computed suggestions. > > The way to determine "If the terminal is a tty" used in this patch > looks overly dangerous, given that we do not know what kind of "git" > command we may be invoking at this point. Indeed, it should also have considered stdin's tty-ness. > Perhaps we should audit "isatty()" calls and replace them with a > helper function that does this kind of thing consistently in a more > robust way (my recent favorite is Linus's somewhat anal logic used > in builtin/merge.c::default_edit_option()). Any specific callers to isatty() you have in mind? A quick grep shows that a significant portion of the "offenders" are isatty(2) calls to determine whether to display progress, I think those are ok. The credential helper has some prompting functionality that is close to what I intend to do here, but I think it can make some assumptions about stdin/stdout that we can't, as you have pointed out. So that leaves merge-edit and this patch as the beneficiaries of a builtin/merge.c::default_edit_option() refactor. That's just off the top of my head. Perhaps the helper function could be named "git_can_prompt()" and placed in prompt.c? -- Cheers, Ray Chuan