From: David Aguilar Date: Thu, 16 May 2013 03:28:33 GMT Subject: Re: [PATCH v6 2/2] imap-send: eliminate HMAC deprecation warnings on Mac OS X Message-ID: In-Reply-To: <7v7gizahcn.fsf@alter.siamese.dyndns.org> On Wed, May 15, 2013 at 5:39 PM, Junio C Hamano wrote: > David Aguilar writes: > >> Mac OS X 10.8 Mountain Lion warns that HMAC_Init() and friends >> are deprecated. Detect the COMMON_CRYPTO_FOR_OPENSSL definition > > Ahh, I think you meant to use that name but forgot to adjust the > symbol you use in the patch ;-) > > I'll queue with s/COMMON_DIGEST_FOR_OPENSSL/COMMON_CRYPTO_FOR_OPENSSL/; The symbol in Apple's header is COMMON_DIGEST_FOR_OPENSSL. I rebased this patch for so many bikesheds I was bound to screw up the commit message ;-) >> diff --git a/imap-send.c b/imap-send.c >> index d9bcfb4..96012b1 100644 >> --- a/imap-send.c >> +++ b/imap-send.c >> @@ -29,8 +29,18 @@ >> #ifdef NO_OPENSSL >> typedef void *SSL; >> #else >> +#ifdef COMMON_DIGEST_FOR_OPENSSL Yup, the symbol is fine. >> +#include >> +#define HMAC_CTX CCHmacContext >> +#define HMAC_Init(hmac, key, len, algo) CCHmacInit(hmac, algo, key, len) >> +#define HMAC_Update CCHmacUpdate >> +#define HMAC_Final(hmac, hash, ptr) CCHmacFinal(hmac, hash) >> +#define HMAC_CTX_cleanup >> +#define EVP_md5() kCCHmacAlgMD5 >> +#else >> #include >> #include >> +#endif >> #include >> #endif -- David