From: Stefan Beller Date: Fri, 05 Oct 2018 23:50:10 GMT Subject: Re: [PATCH v6 08/10] submodule: add a helper to check if it is safe to write to .gitmodules Message-ID: In-Reply-To: <20181005130601.15879-9-ao2@ao2.it> > static int module_config(int argc, const char **argv, const char *prefix) > { > + enum { > + CHECK_WRITEABLE = 1 > + } command = 0; Can we have the default named? Then we would only use states from within the enum?