From: Stefan Beller Date: Thu, 27 Oct 2016 20:57:30 GMT Subject: Re: [PATCH 17/36] attr: expose validity check for attribute names Message-ID: In-Reply-To: On Mon, Oct 24, 2016 at 2:07 PM, Stefan Beller wrote: > On Sun, Oct 23, 2016 at 8:07 AM, Ramsay Jones > wrote: >> >> >> On 23/10/16 00:32, Stefan Beller wrote: >>> From: Junio C Hamano >>> >>> Export attr_name_valid() function, and a helper function that >>> returns the message to be given when a given pair >>> is not a good name for an attribute. >>> >>> We could later update the message to exactly spell out what the >>> rules for a good attribute name are, etc. >>> >>> Signed-off-by: Junio C Hamano >>> Signed-off-by: Stefan Beller >>> --- >> >> [snip] >> >>> +extern int attr_name_valid(const char *name, size_t namelen); >>> +extern void invalid_attr_name_message(struct strbuf *, const char *, int); >>> + >> >> The symbol 'attr_name_valid()' is not used outside of attr.c, even >> by the end of this series. Do you expect this function to be used >> in any future series? (The export is deliberate and it certainly >> seems like it should be part of the public interface, but ...) >> refactoring this series again, I will make use of attr_name_valid outside of attr.c, so I'll keep this patch.