From: Stefan Beller Date: Tue, 22 Nov 2016 20:03:31 GMT Subject: Re: [PATCHv2 2/3] submodule-config: rename commit_sha1 to commit_or_tree Message-ID: In-Reply-To: On Mon, Nov 21, 2016 at 7:37 PM, Junio C Hamano wrote: > Doesn't (the) "above", aka submodule_from_path() want the same > treatment? fixed in a resend. > I do not think the commit-sha1 (or commit-or-tree-object-name) is > "ITS" object name for the submodule. The name belongs to the > containing superproject commit (or tree), no? > > Given a tree-ish in the superproject and a path, return the > submodule that is bound at the path in the named tree. I'll take this. > > is what I would write for that one. Thinking about it a bit > further, "treeish_name" would be a much better name for the variable ok, so treeish_name it is. >> +' > > Perhaps also test a tag that points at the commit? will fix in a resend.