From: Stefan Beller Date: Sun, 11 Sep 2016 16:01:16 GMT Subject: Re: [PATCH v7 03/10] pkt-line: add packet_write_fmt_gently() Message-ID: In-Reply-To: <714C1346-6A7D-4A8B-AAA2-BA936EB6B739@gmail.com> On Sun, Sep 11, 2016 at 4:36 AM, Lars Schneider wrote: >> >> call check_pipe from write_or_die here instead of >> reproducing that function? > > Yes, might be better. I wasn't sure because the check_pipe is > not public. > > Where would you declare check_pipe? In cache.h? IIRC, once upon a time the community decided to not clutter cache.h any more as it is like a dirty kitchen sink, piling up all unrelated things, but on the other hand that would be handy. > Maybe it would be more suitable to move check_pipe to > run-command.h/c? That's certainly possible. I don't have a strong opinion, where the code actually resides, but I do have a strong-ish opinion on code duplication. ;)