From: Stefan Beller Date: Tue, 13 Dec 2016 17:51:11 GMT Subject: Re: [PATCH 6/6] rm: add absorb a submodules git dir before deletion Message-ID: In-Reply-To: <20161213032848.4ps42jinix6fdgdc@genre.crustytoothpaste.net> On Mon, Dec 12, 2016 at 7:28 PM, brian m. carlson wrote: > On Mon, Dec 12, 2016 at 05:40:55PM -0800, Stefan Beller wrote: >> When deleting a submodule we need to keep the actual git directory around, >> such that we do not lose local changes in there and at a later checkout >> of the submodule we don't need to clone it again. >> >> Implement `depopulate_submodule`, that migrates the git directory before >> deletion of a submodule and afterwards the equivalent of "rm -rf", which >> is already found in entry.c, so expose that and for clarity add a suffix >> "_or_dir" to it. > > I think you might have meant "_or_die" here. indeed, will fix in a reroll. Thanks for the review!