From: Stefan Beller Date: Sat, 14 Nov 2015 00:43:41 GMT Subject: Re: [PATCH 1/3] prepare_packed_git(): find more garbage Message-ID: In-Reply-To: <1447459853-28838-2-git-send-email-dougk.ff7@gmail.com> > + else if (seen_bits & PACKDIR_FILE_PACK && seen_bits ^ ~PACKDIR_FILE_IDX) as just talked about: did you mention && !(seen_bits & FILE_IDX) > > + if (seen_bits == (PACKDIR_FILE_PACK|PACKDIR_FILE_IDX|PACKDIR_FILE_BITMAP)) > + return; > + > + if (seen_bits == (PACKDIR_FILE_PACK|PACKDIR_FILE_IDX|PACKDIR_FILE_KEEP)) > + return; > + > + if (seen_bits == (PACKDIR_FILE_PACK|PACKDIR_FILE_IDX|PACKDIR_FILE_BITMAP|PACKDIR_FILE_KEEP)) > + return; I wonder if this should be rewritten as if (seen_bits & FILE_PACK && seen_bits & FILE_IDX && (seen_bits & FILE_KEEP || seen_bits & BITMAP)) return; to dense it a bit. ;)