From: Stefan Beller Date: Tue, 26 Apr 2016 01:08:39 GMT Subject: Re: [PATCH] clone: add `--shallow-submodules` flag Message-ID: In-Reply-To: On Mon, Apr 25, 2016 at 3:37 PM, Junio C Hamano wrote: > Stefan Beller writes: > >> I agree. How about `currentdir`, `testdir` or `testtop` instead? >> That is slightly longer than `D`, `here` or `top`, but is slightly more >> informative. $TRASH would also work for me. > > I would not be happy to see a patch that adds yet another variable > that is never used so far, like currentdir, testdir, or testtop. D seems to be popular in 5510, the submodule crowd seems to prefer $pwd though, see t5526-fetch-submodules.sh t7406-submodule-update.sh t7407-submodule-foreach.s t7400-submodule-basic.sh as grep -r "\$pwd" put it. > > Among the ones I found that are already in use, $here is probably my > favourite, because it does _not_ have to be set to the top; it just > says "this is the directory my main focus is in". > > Having said that, personally, I find $D (as long as D is in capital) > is distinctive and descriptive enough. I rather go with pwd for now (it keeps the submodule stuff consistent), Thanks, Stefan